macOS 11 (Big Sur) Support for Avid Products

We recommend that you continue to use previously qualified operating systems until further notice.

Last Updated : November 19, 2020

We recommend that you continue to use previously qualified operating systems until further notice. (For the latest information on macOS Catalina support, please visit this knowledge base article).

Products Affected : Media Composer, Pro Tools, Sibelius, Avid NEXIS, Media Composer First, Media Composer Ultimate, Pro Tools First, Pro Tools Ultimate, Sibelius First, Sibelius Ultimate, Media Composer Enterprise

Many Avid products run on Macs, including Pro Tools, Media Composer, and Sibelius. For Avid products that run on the Mac, Avid has been working to support macOS Big Sur and the new M1-powered Macs over the past several months in anticipation of these releases.

Please subscribe to this article on the Avid Knowledge Base CLICK HERE ,¬† or visit your product’s specifications page regularly for information on the current operating system requirements.

In the meantime, we recommend that you continue to use previously qualified operating systems until further notice. (For the latest information on macOS Catalina support, please visit this knowledge base article).

 

Please call Altered Images on 01932 255 666 for more info